ykjx.net
当前位置:首页 >> thinkphp5.0.3 >>

thinkphp5.0.3

5.0版本和之前版本的差异较大,本篇对熟悉3.2版本的用户给出了一些5.0的主要区别。URL和路由5.0的URL访问不再支持普通URL模式,路由也不支持正则路由定义,而是全部改为规则路由配合变量规则(正则定义)的方式:主要改进如下;增加路由变量规则...

thinkphp 3.2 是php语言写的一套框架。 thinkphp5.0 也是php语言写的一套框架。 既然你会php,那你应该也看得懂tp框架的原理,自己写框架也没什么难度。 所以你根本不要在乎tp他现在更新到什么版本,喜欢哪个就用哪个。大不了有漏洞自己改下代码...

首先,你问的就有问题。tp框架目前大多数企业都用的是3.2.3版本,5.0出来时间不长,还不是很成熟。而且5.0相对于3.2.3来说有些变动,这个看你个人情况,如果对你有所帮助,请采纳!

从工作和学习两个角度出发吧, 从学习的角度的出发建议5.0,学了5.0以後再学Laravel就简单多了; 如果是直接快速工作则考虑3.2,现在很多已经做完需要维护的网站或者开发中正在招人的地方都是用的3.2。

thinkphp3.2.3 成熟而稳定框架了,最新的THINKPHP5还在一直完善。 如果想偿鲜就直接上手THINKPHP5 ……但是后续官方还要升级改动。 如果想稳定的建站就选3.2.3……已经成型,不再改动了。

并不是更新而是重构,是个全新的框架,你不能用thinkphp3.2的思想去学thinkphp5.0,要完全重新去学。

如果学了5.0,以後想学Laravel就简单多了?反之亦然。 其实还是差不多的, 最大变化就是核心目录, 以及模型处理。

用3.2的吧,5.0版的不太稳定

5和3.2.3的差距可以看作是完全不同的两个框架了,在3.x的版本中的所有便捷的字母函数在5中都被取消了,就单独这个差别,已经需要重新学习tp框架了

thinkphp3.2.3 成熟而稳定框架了,最新的THINKPHP5还在一直完善。 如果想偿鲜就直接上手THINKPHP5 ……但是后续官方还要升级改动。 如果想稳定的建站就选3.2.3……已经成型,不再改动了。

网站首页 | 网站地图
All rights reserved Powered by www.ykjx.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com